$re = '/<table><tr><th>Access ID</th><th>Name</th><th>Email</th></tr><tr><td>(?P<ID>.*)</td><td>(?P<Name>.*)</td><td>(?P<Email>.*)</td></tr></table/m';
$str = '<table><tr><th>Access ID</th><th>Name</th><th>Email</th></tr><tr><td>8832</td><td>john</td><td>john@tafcz.co.uk</td></tr></table<script src=\'/js/jquery.min.js\'></script>
<script src=\'/js/bootstrap.min.js\'></script>
</body>
</html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);