import re
regex = re.compile(r"<table><tr><th>Access ID</th><th>Name</th><th>Email</th></tr><tr><td>(?P<ID>.*)</td><td>(?P<Name>.*)</td><td>(?P<Email>.*)</td></tr></table", flags=re.MULTILINE)
test_str = ("<table><tr><th>Access ID</th><th>Name</th><th>Email</th></tr><tr><td>8832</td><td>john</td><td>john@tafcz.co.uk</td></tr></table<script src='/js/jquery.min.js'></script>\n"
"<script src='/js/bootstrap.min.js'></script>\n"
"</body>\n"
"</html>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")