package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\B#worldemojiday\b`)
var str = `Fall in love with #PepsiMoji! Celebrate #WorldEmojiDay by downloading our keyboard @ http://bit.ly/pepsiKB & take your text game up a notch. - teacher`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}