re = /\B#worldemojiday\b/i
str = 'Fall in love with #PepsiMoji! Celebrate #WorldEmojiDay by downloading our keyboard @ http://bit.ly/pepsiKB & take your text game up a notch. - teacher'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end