const regex = new RegExp('^((?![IOSZ])[A-Z]){3}-[^3]{4}$', 'gm')
const str = `ARA-444Z
AOA-444Z
ATA-443Z
AKP-454Z
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}