re = /^((?![IOSZ])[A-Z]){3}-[^3]{4}$/m
str = 'ARA-444Z
AOA-444Z
ATA-443Z
AKP-454Z
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end