package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-?(?:0|[1-9]\d*)(?:.\d*)?(?:[eE][-+]?\d*)?)`)
var str = `12
1.12e4
0e122
12.3
0.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}