$re = '/(-?(?:0|[1-9]\d*)(?:.\d*)?(?:[eE][-+]?\d*)?)/m';
$str = '12
1.12e4
0e122
12.3
0.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);