using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xsm) # free-spacing mode, DOTALL, multi-line
(?=.*?blue) # if blue isn't there, fail without delay
########### LINE SKIPPER / COUNTER ############
(?: # start non-capture group
# the aim is to skip lines that don't contain blue
# and capture a corresponding digit sequence
(?: # skip one line that doesn't contain blue
^ # beginning of line
(?:(?!blue)[^\r\n])* # zero or more chars
# that do not start blue
(?:\r?\n) # newline chars
)
# With each line skipped, let Group 1 capture
# an ever-growing portion of the string of numbers
(?= # lookahead
.* # Go to the end of the file
( # start Group 1
~\d+ # match a tilde and digits
(?(1)\1) # if Group 1 is set, match Group 1
) # end Group 1
) # end lookahead
)*+ # end counter-line-skipper: zero or more times
# the possessive + forbids backtracking
.*? # lazily match any chars up to...
blue # match blue
.* # Get to the end of the data
~ # match a tilde
\K # drop what we matched so far
\d+ # match digits. This is the match!
(?=(?(1)\1)) # if Group 1 has been set, match it
";
string substitution = @"";
string input = @"Paint it white
Paint it black
Why not blue?
Or red or brown?
~10~9~8~7~6~5~4~3~2~1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}