// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{0,7}(?:\.\d{2}|\d{0,2})$").unwrap();
let string = "Match type:
.01
1
1.01
0
1234567.89
Unmatch type:
.012
1.098
123.456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}