#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?([^.]*)(?=(?:\.com|\.org|\.info|\.org|\.net|\.mobi)).*$"
Local $sString = "http://www.youtube.com/v/0PsnoiwMrhA" & @CRLF & _
"https://www.youtube.com/v/0PsnoiwMrhA" & @CRLF & _
"www.youtube.com/v/0PsnoiwMrhA" & @CRLF & _
"http://youtube.com/v/0PsnoiwMrhA" & @CRLF & _
"youtube.com/v/0PsnoiwMrhA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")