import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?([^.]*)(?=(?:\\.com|\\.org|\\.info|\\.org|\\.net|\\.mobi)).*$";
final String string = "http://www.youtube.com/v/0PsnoiwMrhA\n"
+ "https://www.youtube.com/v/0PsnoiwMrhA\n"
+ "www.youtube.com/v/0PsnoiwMrhA\n"
+ "http://youtube.com/v/0PsnoiwMrhA\n"
+ "youtube.com/v/0PsnoiwMrhA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}