package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-) .(+]?[0-9]{3}(?:[-) .(+]+)?[0-9]{3}(?:[-) .(+]+)?[0-9]{3,4}$`)
var str = `(123) 456 7899
(123).456.7899
(123)-456-7899
123-456-7899
123 456 7899
1234567899
+123456789
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}