$re = '/^[-) .(+]?[0-9]{3}(?:[-) .(+]+)?[0-9]{3}(?:[-) .(+]+)?[0-9]{3,4}$/m';
$str = '(123) 456 7899
(123).456.7899
(123)-456-7899
123-456-7899
123 456 7899
1234567899
+123456789
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);