package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:\$|сум)(\040)?(\d{0,8})|(\d{0,8})(\040)?(?:\$|сум)`)
var str = `$23
23$
1000сум
сум1000
сум 1000
1000 сум`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}