re = /(?:\$|сум)(\040)?(\d{0,8})|(\d{0,8})(\040)?(?:\$|сум)/mi
str = '$23
23$
1000сум
сум1000
сум 1000
1000 сум'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end