import Foundation
let pattern = #"include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
h1
=title
include 'atoms-square'
#container.col
if youAreUsingJade
p You are amazing
else
p Get on it!
p.
Jade is a terse and simple
templating language with a
strong focus on performance
and powerful features.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}