import re
regex = re.compile(r"((?:(?:https?|ftp)+(?:\:\/\/))?)+(?:(?:(?:www(?:(?:[\d]{1})?)\.|[a-z0-9-_]{1,}))+\.(?:com|me|ru|net|biz|info|fm|su|ua|to|us|[a-z]{1,5}))+(?:(?:[a-z0-9\/\?=-_.&]{1,})?)", flags=re.IGNORECASE | re.DOTALL | re.MULTILINE)
test_str = "Дорого времени суток, составил регулярку для парсинга ссылок вида http://example.com/ http://www.example.com/, www.example.com, example.com, example.com?act=1 и тд и тп, вот регулярка:"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")