package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,2}:\d{1,2};?)+$`)
var str = `5:2;7:7;5:2;
5:2;7:7;5:2
9:9;
9:9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}