$re = '/^(?:\D*\d){10}\D*$/';
$str = 'hh1h2h3h4h5h6h7h8h9h0---jj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);