import Foundation
let pattern = #"^(?:\D*\d){10}\D*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hh1h2h3h4h5h6h7h8h9h0---jj"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}