#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:(?:([a-z])(?=[a-z]*\1))+(?!\1))?([a-z])(?![a-z]*\2)"
Local $sString = "'NUNUMUNN' // expected output 'M'" & @CRLF & _
"'LOMING' // expected output 'L'" & @CRLF & _
"" & @CRLF & _
"I think it's possible to do this using general string operations, but my preference is really for pure regex." & @CRLF & _
"" & @CRLF & _
"AAAAAAAAAAAAAAAAAAAAAA" & @CRLF & _
"" & @CRLF & _
"AXXXXXA" & @CRLF & _
"" & @CRLF & _
"XXXXXXA" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")