using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+?\d{1,3}|\d{1,4})$";
string input = @"+1
1
+12
12
+123
1234
+
+1234
12345
1+
12+
<empty>
etc.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}