// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+?\d{1,3}|\d{1,4})$").unwrap();
let string = "+1
1
+12
12
+123
1234
+
+1234
12345
1+
12+
<empty>
etc.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}