$re = '/^[\w.-]+@[A-Za-z0-9]+\.[A-Za-z]{3}$/';
$str = 'foo@bar.baz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);