import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img(.*?)src=(?:'|\")((?:.*?)\\.(?:gif))(?:'|\")(.*?)\\/?>";
final String string = "<img id=\"image-767050065729cd0d0ee13\" class=\"marker-true-tag \" data-gif=\"./static/images/5729cb54611d945c5d72684c.png\" alt=\"\" /><img id=\"image-9990266295729cd0cdca60\" class=\"marker-true-tag \" src=\"./static/images/5721edcd611d941b17569aa2.png\" alt=\"\" /><img id=\"image-3574931435729cd0ca6721\" class=\"marker-true-tag \" src=\"./static/images/56322568611d94ae6756a8a1.png\" alt=\"\" /><img id=\"image-13612540315729cd0cc267c\" data-gif=\"./static/images/5729d37c611d94c56072684c.gif\" class=\"marker-true-tag \" src=\"\" alt=\"\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}