import Foundation
let pattern = #"<img(.*?)src=(?:'|")((?:.*?)\.(?:gif))(?:'|")(.*?)\/?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"<img id="image-767050065729cd0d0ee13" class="marker-true-tag " data-gif="./static/images/5729cb54611d945c5d72684c.png" alt="" /><img id="image-9990266295729cd0cdca60" class="marker-true-tag " src="./static/images/5721edcd611d941b17569aa2.png" alt="" /><img id="image-3574931435729cd0ca6721" class="marker-true-tag " src="./static/images/56322568611d94ae6756a8a1.png" alt="" /><img id="image-13612540315729cd0cc267c" data-gif="./static/images/5729d37c611d94c56072684c.gif" class="marker-true-tag " src="" alt="" />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)