import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(#+)([a-zA-Z_\\x7f-\\xff][a-zA-Z0-9_\\x7f-\\xff]*)((?:\\>[a-zA-Z0-9_\\x7f-\\xff]*)*)\\}\\s*(\\{\\1\\>empty\\}\\s*(.*?)\\s*\\{\\1\\>empty\\})?\\s*([^\\n]*)\\s*(\\{\\1\\>firstrow\\}\\s*(.*?)\\s*\\{\\1\\>firstrow\\})?\\s*(\\{\\1\\>row\\}\\s*(.*?)\\s*\\{\\1\\>row\\})?\\s*(\\{\\1\\>lastrow\\}\\s*(.*?)\\s*\\{\\1\\>lastrow\\})?\\s*(.*?)\\s*\\{\\1\\}";
final String string = "{#var1>var2}\n"
+ " {#>empty}inside empty{#>empty}\n"
+ " before rows\n"
+ " {#>firstrow}inside firstrow{#>firstrow}\n"
+ " {#>row}inside row{#>row}\n"
+ " {#>lastrow}inside lastrow{#>lastrow}\n"
+ " after rows\n"
+ "{#}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}