import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>((?:(?:(?!<div[^>]*>|<\\/div>).)+|<div[^>]*>(?1)<\\/div>)*)<\\/div>";
final String string = "<div class=\"cls1\">\n"
+ " Hello\n"
+ " <p></p>\n"
+ " <div id=\"id1\">\n"
+ " Hi mohammad\n"
+ " </div>\n"
+ " <div></div>\n"
+ "</div>\n"
+ "<div class=\"cls1\">\n"
+ " Hello\n"
+ " <p></p>\n"
+ " <div id=\"id1\">\n"
+ " Hi mohammad\n"
+ " </div>\n"
+ " <div></div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}