import re
regex = re.compile(r"<div[^>]*>((?:(?:(?!<div[^>]*>|<\/div>).)+|<div[^>]*>(?1)<\/div>)*)<\/div>", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<div class=\"cls1\">\n"
" Hello\n"
" <p></p>\n"
" <div id=\"id1\">\n"
" Hi mohammad\n"
" </div>\n"
" <div></div>\n"
"</div>\n"
"<div class=\"cls1\">\n"
" Hello\n"
" <p></p>\n"
" <div id=\"id1\">\n"
" Hi mohammad\n"
" </div>\n"
" <div></div>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")