const regex = /\bbaz=([^=&]+(?:&[^=&\n]+)*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bbaz=([^=&]+(?:&[^=&\\n]+)*)', 'g')
const str = `foo=bar&baz=qux&norf&corge=grault
foo=bar&baz=qux&norf
foo=bar&baz=qux&norf
foo=bar&baz=qux&norf&bax&more_stuff
baz=sdasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}