$re = '/\bbaz=([^=&]+(?:&[^=&\n]+)*)/';
$str = 'foo=bar&baz=qux&norf&corge=grault
foo=bar&baz=qux&norf
foo=bar&baz=qux&norf
foo=bar&baz=qux&norf&bax&more_stuff
baz=sdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);