import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "user_search\\\"=>\\{\\\"name\\\"=>(?<result>.*)";
final String string = "I, [2021-09-23T00:46:31.172197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"aniket\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
+ "host = qa-1132-lx02source = /src/project.logsourcetype = data:log\n\n"
+ "I, [2021-09-23T00:48:31.162197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"shivam\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
+ "host = qa-1132-lx02source = /src/project.logsourcetype = data:log\n\n"
+ "I, [2021-09-23T00:52:27.171197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"tiwari\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
+ "host = qa-1132-lx02source = /src/project.logsourcetype = data:log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}