# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"user_search\"=>{\"name\"=>(?<result>.*)"
test_str = ("I, [2021-09-23T00:46:31.172197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"aniket\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
"host = qa-1132-lx02source = /src/project.logsourcetype = data:log\n\n"
"I, [2021-09-23T00:48:31.162197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"shivam\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
"host = qa-1132-lx02source = /src/project.logsourcetype = data:log\n\n"
"I, [2021-09-23T00:52:27.171197 #44154] INFO -- : [651235bf-7ad5-4a2e-a3b8-7737a3af9fc3] Parameters: {\"user_search\"=>{\"name\"=>\"tiwari\", \"has_primary_phone\"=>\"false\", \"query_params\"=>{\"searchString\"=>\"\", \"start\"=>\"0\", \"filters\"=>[\"\"]}}}\n"
"host = qa-1132-lx02source = /src/project.logsourcetype = data:log")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.