package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)field\s*=\s*([^\s]+)\s*value\s*=\s*([^\s]+)`)
var str = `field = a value = 1345 field = b value = 3453 field = be value = 34.53l`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}