$re = '/field\s*=\s*([^\s]+)\s*value\s*=\s*([^\s]+)/im';
$str = 'field = a value = 1345 field = b value = 3453 field = be value = 34.53l';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);