re = />(.*?)(?:<|$)/
str = '<ahref=https://blabla.com/Securities_regulation_in_the_United_States>Securities regulation in the United States</a> - Securities regulation in the United States is the field of U.S. law that covers transactions and other dealings with securities.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end