package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+\w*\b`)
var str = `he will be 60 years old today
she turns 79yo today this afternoon`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}