re = /\b\d+\w*\b/
str = 'he will be 60 years old today
she turns 79yo today this afternoon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end