package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]{4}^\btion\b|[a-z]{6}^\bable\b)`)
var str = `abortion`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}