$re = '/([a-z]{4}^\btion\b|[a-z]{6}^\bable\b)/m';
$str = 'abortion';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);