const regex = /([1-9][0-9][0-9][0-9]|[1-9][0-9][0-9]|99)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9][0-9][0-9][0-9]|[1-9][0-9][0-9]|99)', '')
const str = `9293`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}