$re = '/([1-9][0-9][0-9][0-9]|[1-9][0-9][0-9]|99)/';
$str = '9293';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);