const regex = /[1-9]\d{2,6}|99/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[1-9]\\d{2,6}|99', '')
const str = `You will likely be eaten by 1000 grue.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}