$re = '/[1-9]\d{2,6}|99/';
$str = 'You will likely be eaten by 1000 grue.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);