package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\{[^}]*}`)
var str = `${apples} ${turtles} ${elephants} `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}