$re = '/\$\{[^}]*}/m';
$str = '${apples} ${turtles} ${elephants} ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;