package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\>([^<]*)\<\}\!?\[([^\]]+)\]\(([^\)]*)\)(\w*\S*)*`)
var str = `{>"id"<}and_the_rest`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}