re = /\{\>([^<]*)\<\}\!?\[([^\]]+)\]\(([^\)]*)\)(\w*\S*)*/
str = '{>"id"<}and_the_rest'
# Print the match result
str.match(re) do |match|
puts match.to_s
end