#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/(?:\/|\/\s)razor:([^~]*?=)([^~]*?;)[^*]+?\/(?:\/|\s)endrazor"
Local $sString = "var exp = module.exports = {};" & @CRLF & _
"" & @CRLF & _
"var pageIsLoaded = true;" & @CRLF & _
"//razor:var cttCipher = [@Raw(Model.CipherText)];" & @CRLF & _
"var cttCipher = ["U2FsdGVkX19f2rSF8G7sSSKwr+JWsEZYySfbePfitkbo462FKaIJNOc/v5V8+h"" & @CRLF & _
","Vo4k5dHornELJHfTx2h+XsXQstYXFL13QdRFQ5v0OfWNIubrYlnQBm6DOdHKQlJ44j2RJLg2cknFDX0"" & @CRLF & _
","bwBWvXCP2/db6HShj9/NtdusBUcGf62bnZC1ADeFxKnR+r6Sa8SNEk2AAlq8k6cN0z4EpL/WgQrGVNe"" & @CRLF & _
","+nmAlLxxY1MexWZ0rWc5pjlubyddKK9Z+jbcbXqmseED1iXPHjcmGsPHrMQIylWmt2jXaw6bq/8IVrF"" & @CRLF & _
","UgqZPL1ICfWF7bTy3SNkI+t6o/vEvq1GJ9iqvn7qQyPrqCL2ztuORPhPwMGP7ZzzVUozT+c7Wj1X2eU"" & @CRLF & _
","qkgxjpECjmJiigXFHCv/vWC/Yk4+oK644ajGknDFvt7dQKb320uJHdfNuuFAZiVQ2DrSfxq+DIWe4pj"" & @CRLF & _
","PPFWCArZ566vRzZRENA9l2lIQmWga8q+/LVirG+/wGWzC/QXMypLPRa+l3WUl6pm918RPCZOkzUtfb3"" & @CRLF & _
","zSaLX9b6cuSOw1KJfjpvwWOu1RVAEtRzN8cn9B6zNlXFlDlo1x57H/4Bo760JMpn8mbLZq4yW5cg2T4"" & @CRLF & _
","n61sIpFjDVArQPvEzep7N+nVtq3apqeHo/Uge3WA/81o0lo1jJY2duUZgakK5Bm5nN1hJDHrQeexGrl"" & @CRLF & _
","DAAaPmR5OdbM8IeNeu1NF9c0NnGXUnskNnlHZwODCQNCrz/xRbLMNdfPOjCUjVn36H1nRT+ngGS/c/8"" & @CRLF & _
","iiGQy1iBGWycnVvbkQF0UWdzXrw1miqBkj8f7eKup1GEYn+ylVBM6VeboPez2UOLU3VfzGmj0w3yb4f"" & @CRLF & _
","h5YbxZI1TzLIFFONHuj1DTpr49BEb9Q3QeSUHytn0msnvLKpgDxFg03gTnu+BXypM94ynil38d3saIA"" & @CRLF & _
","J+Qe8DSdZfsXHo6zegvYWUQl+px8Ti3+pc7T3zs/1iDFEvkGDJyIJOxhQBx0DfYi8tUxV+WXA3czDL4"" & @CRLF & _
","WZnOYNOLr5vljZrVhAQglg6bcZlFIj/HqXwf23zUmnUHWAFuPKlUk7NpMejtBw8EuMOJIncdGZSZV9r"" & @CRLF & _
","luzuZoK6gfBYPUd1mzRtoY7dQqZ3UYvzBNuXOyb2IPSrEEQXzeYFhDz8lC5JRpHN+gPzKVoLyK9pnl9"" & @CRLF & _
","Xzb9ZthQXdTKOoHAWQ8Rtoq2DSfZaF60edOUVFSTZkhw1IrcJ9mP8oUTCSMiLvNqwg0+1KsfF0dMrQs"" & @CRLF & _
","QnmQnbMoiaofGPNvcEfDrvYQhVfk71/ZbgN/RQHejqwEBQ2EL51niE7qm2fOvnPyglpD+E0sTIcRP8T"" & @CRLF & _
","oQRV40wINFNiYnzUwBnQhxQLU6QugZQnYUGoYhWWIf/x00sRNAC87xcViOmadVPWs0qsICZJgPqPOKk"" & @CRLF & _
","L/ql3Us5ENQg+xfdStQ4fyljPBFnX+OXlSMfKbueKwSh58fq5hNw6Slk/jYYlnqI+uagNypHkOv5PlI"" & @CRLF & _
","kyPXNLDzN+2jU8c4GIBhLf5OMOo66p24qI2BFA7CJfEQGZcuvXH6rKm6vVD08OGlNpaaQ4bXXcKVwys"" & @CRLF & _
","EUPnUp8M8FR5ju7M="]" & @CRLF & _
"//endrazor" & @CRLF & _
"" & @CRLF & _
"exp.decrypt = function () {" & @CRLF & _
" if (!pageIsLoaded) {" & @CRLF & _
" alert('Aguarde a p\xe1gina carregar.');" & @CRLF & _
" return;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" var txtpass = document.getElementById('txt-pass');" & @CRLF & _
" var passHash = Core.SHA512(txtpass.value);" & @CRLF & _
" var txtCipher = cttCipher.join('');" & @CRLF & _
" // razor: var iniVector = Core.enc.Hex.parse('@Model.InitializationVector');" & @CRLF & _
" var iniVector = Core.enc.Hex.parse('@Model.InitializationVector');" & @CRLF & _
" //endrazor" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"var pageIsLoaded = true;" & @CRLF & _
"//razor:var cttCipher = [_____@Raw(Model.CipherText)___];" & @CRLF & _
"var cttCipher = ['@Raw(Model.CipherText)'];" & @CRLF & _
"// endrazor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")